Asking for help: LoTRO Welcome Back weekend

Lord of the Rings online has a Welcome Back Weekend offer for former subscribers. That’s cool, but I can’t figure out how my old account (which was left in good standing when I unsubscribed) gets enabled for the Welcome Back Weekend.

When I attempt to log in, I’m told that my account does not have an active LoTRO subscription. Well, duh.

I might be overlooking the obvious on the LoTRO website, or in their forums, but I can’t find information anywhere about how my account would be allowed to log back in for the free weekend of play. Does anyone know what I’m missing?

About these ads

7 Responses

  1. I’ve never unsubbed from LOTRO since I have the Lifetime but I would guess you first need to login to https://myaccount.turbine.com/ to re-enable things.

  2. That’s what I thought too, but there’s nothing about the Welcome Back weekend when you log in to the account management page. Thanks for the suggestion, though!

  3. I dunno, I was just able to log in when the weekend started (I checked before, it accepted my login but said I didn’t have a current subscription and offered a reactivate link, but it was fine with letting me play on Friday). I don’t think I did anything differently from a normal launch game -> login.

  4. Yeah, apparently I’m missing something in my Turbine account that would let me in.

    I mailed Turbine support, but I might not hear from them until the free weekend is over. Oh well :)

  5. well… nuts! I hope you get it figured out. Sounds like a bug

  6. I know it’s too late now, since the weekend is over, but you had to add your credit card information inorder to reactivate the account. I only know this because I got in on the tail end of the weekend but was subbing back up anyway.

  7. I don’t know what changed, Oak, but I finally got all the necessary tabs back in my Turbine account management page. My credit card info was still valid from the last time I played, but I didn’t have a tab that would let me re-activate. I couldn’t see the credit card info either…but it did show up yesterday after the server maintenance, so I suspect that had something to do with it.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: